『Arrays are not allowed in class constants』さくらサーバーのSSL化プラグインが有効化出来ない時の対処法。

Pocket

Arrays are not allowed in class constants in /home/mtweb/www/asucrie/wp-content/plugins/sakura-rs-wp-ssl/modules/model/force-ssl.php on line 32

さくらサーバーをご利用の方でサイトのSSL化を行う際に上記のエラーが出て有効化出来ないことがあります。

そのエラーの原因はPHPのバージョンにあります。

さくらサーバーのコントロールパネルのPHPのバージョンを確認しましょう。

SSL化プラグインを有効にするにはPHPのバージョンが5.6 もしくは7.1以上でないと有効化出来ません。

サーバーレンタルが古い場合など、初期に導入したPHPだと5.2のままであったりと古いままの人は多いのではないでしょうか?

 

そんな時はPHPのバージョンを上げて再度テストしてみてください。

 

コメントを残す

メールアドレスが公開されることはありません。 * が付いている欄は必須項目です